USB is not formatting

Mittroooo i have SANDISK 8GB pen drive , os vich 5-6 HD movies haigian, oh na ta Rename hundian , nah ta delete hundian, evn cut,rename,delete di optin hi ni aandi. Jado format kriye ta error aanda = DISK DRIVE IS PROTECTED :kiven
NOTE - mere PC te koi Virus ni haiga :cadmin

kit walker

Prime VIP
Staff member
HP da USB format tool use kar ke dekh lavo je ho gaye. or Try
1 Pull the USB flash drive out of your computer's USB port. Check the bottom end and sides of the drive to see if it has a write protection switch. Push the plastic switch into the "Unlock" position.
2 Insert the USB flash drive back into the USB port. Close the pop-up window that appears and navigate to the Start menu. Select "My Computer."
3 Locate the drive letter that corresponds to your USB flash drive in the "My Computer" window, such as "F:\" or "D:\." Double-click the drive letter. Attempt to use one of the files on the drive. Right-click one of the files if you still receive a write protection error and select "Properties."
4 Navigate to the "General" tab and remove the check mark from the box labeled "Read-Only." Click "Apply" and then attempt to use the file.
5 Return to the Start menu and click "Run." Type "Regedit" and press "Enter." Navigate to the registry folder "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies."
6 Check if there is an entry at the right side of the window labeled "Write Protect". If the entry is not there Right-click inside the window and choose "New D Word." Type "Write Protect" and press "Enter."
7 Double-click the "Write Protect" entry. Check that the value listed in the text box is "0." If it is not, delete the value and replace it with "0."
8 Close the registry editor and attempt to use any of the files on the USB drive. Return to the "My Computer" window if you continue to receive a write protection error message.
9 Right-click the drive letter for the USB flash drive and choose "Format." Click the drop-down menu named "File System" and select "Fat32."
10 Click "Start" to format the USB flash drive and remove the write-protection feature.

or also check
The files could have been marked as Read only somehow. Check the Properties of one of the files and see what show up at the bottom of the Properties page.

If it shows Read Only, change the attribute of all the files on the stick using the Command Prompt and by typing:-
attrib -r x:\*.*
then press Enter. The x above has to be replaced by the actual driver letter of the stick at that time.

hope it would work